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Chapter 1

Introduction
Description

Intermec Printer Network Manager (IPNM) is a
software tool that provides centralized remote printer
management across a TCP/IP network. It runs under
most Microsoft Windows operating systems. It ships
with all printers on the Printer Companion CD.
The purpose of IPNM is to let you remotely manage,
supervise, and control Intermec printers that are
connected to an Ethernet network. Full functionality requires that the printer is fitted with an EasyLAN
100i interface board.
IPNM is a powerful tool that enables the printers to
send real-time Email alerts in case of problems such as
out-of-paper, head lifted, or out-of-ribbon. Alerts can
be forwarded to any Email-enabled device, such as a
text pager, a cellular phone, or a PC.
The Intermec Printer Network Manager gives the network administrator:
• Full management of all printers from a central location. Easy overview and access to all printers on the
network.
• The ability to group printers into functional groups
for easier management. Easy to use and easy to
administrate large printer populations.
• Real-time alert messaging from each printer or
group.
• Error and alert statistical reports by group or by
printer.
You can also change printer settings using the printer’s
home page, Telnet, or remote keyboard. FTP lets you
download files to the printer.
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Requirements

Printer
• Intermec EasyCoder printer with the EasyLAN
100 interface, such as 501XP, 601XP, F2, F4, PF2i,
PF4i, and PM4i (full functionality)
• Intermec EasyCoder printer with the EasyLAN 10
or the EasyLAN Wireless interface (limited functionality)
• Intermec Fingerprint v7.61 (or higher) or IPL v2.00
(or higher).

Computer
• PC with at least 20 MB free disk space (more if you
want to keep a log file).
• Microsoft Windows NT4/2000/XP (preferred) or
Microsoft Windows 95/98/Me.
• Internet Explorer v5.01 or later.
• SNMP Port 161 and 162 must be available.
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Chapter 2

Installing IPNM
Instructions

You can get the free installation file from the Printer
Companion CD or from the Intermec web site
(http://www.intermec.com).
To install IPNM
1. Copy or download the installation file to your PC.
2. Double-click the Install icon and the Wise Installation Wizard starts installing IPNM.

3. Read this introduction screen and then click Next.
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Instructions,
cont.

4. Carefully read this Intermec End User License
Agreement. If you accept the agreement, click the I
accept the license agreement option and then click
Next.
If you do not accept the agreement, click the I do
not accept the license agreement option. The
installation will be cancelled.

5. Read the Readme information to find out what’s
new in this version of IPNM and then click Next.
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Instructions,
cont.

6. Choose which IPNM Configuration Console mode
you want to use initially and then click Next.
• View mode is the easiest mode to use. It simply
lets you manage the networked printers.
• Alert mode is a more advanced mode. It not only
lets you do everything you could do in View
mode, but also it lets you collect statistics and
send Email alerts for common printer problems.
While running IPNM, you can switch modes at any
time.
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Instructions,
cont.

7. Click Browse to browse to the folder where you
want to install IPNM and then click Next.
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Instructions,
cont.

8. This window indicates that the installation is complete. Click Finish.

You can now run IPNM. Depending on your Windows operating system, you may operate IPNM
differently. For help, see:
• Windows NT4, 2000, and XP in the next section.
• Windows 95, 98, and Me later in this chapter.
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Windows NT4,
2000, and XP

In Windows NT4, 2000, and XP, the preferred environment for IPNM is for it to run as a service.
You can start IPNM by opening the Start Menu and
then selecting Programs → Intermec Printer Nework
Manager → Intermec Printer Network Manager.
Or, you can open the Control Panel and then doubleclick the Intermec Printer Network Manager icon.
You can also configure the Windows operating system
to start IPNM automatically when the PC is turned
on.
To conﬁgure Windows to start IPNM automatically
1. From the Start menu, select Settings → Control
Panel.
2. In the Control Panel, double-click the Administrative Tools icon and then double-click the Services
icon.
3. In the Services dialog box, double-click the Intermec
Printer Network Manager option.

Doubleclick
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Windows NT4,
2000, and XP,
cont.

4. Click the General tab.
5. Click the down arrow on the right side of the
Startup type field. A drop-down list box appears.
6. Choose one of these options:
• Automatic (IPNM starts automatically when the
Windows operating system starts).
• Manual (You must manually start IPNM).
• Disabled (You will not be able to start IPNM
until you select Automatic or Manual in this
dialog box).

7. Click Apply and then click OK.

Intermec Printer Network Manager v2.0 — User’s Guide

11

Chapter 2 — Installing IPNM

Windows 95, 98,
and Me

In Microsoft Windows 95, 98, and Me, you can start
IPNM by opening the Start Menu and then selecting
Programs → Intermec Printer Nework Manager →
Intermec Printer Network Manager.
Or, you can configure IPNM to start as soon as the
Windows operating system has started and any login
sequence has been completed.
The IPNM icon appears in the System Tray in the
bottom right corner of your screen (next to the clock).

Intermec Network Printer Manager icon

When you click the IPNM icon, the following menu
appears:
• Configuration console
• About
• Help
• Exit
To conﬁgure IPNM to start automatically
1. Open the IPNM Configuration Console.
2. Check the Load on startup check box.
3. Click Apply.
The next time you turn on your PC, IPNM will start
automatically and you will see the IPNM icon in the
System Tray.
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Starting IPNM
IPNM Control
Panel

From the Start Menu, select Programs → Intermec
Printer Network Manager → Intermec Printer Network Manager. Or, in the Windows Control Panel
window, double-click the Intermec Printer Network
Manager icon.

Intermec Printer Network
Manager icon

The Intermec Printer Network Manager Control Panel
appears.

The Load on startup check
box only appears if your PC is
running Windows 95/98/Me.

In the IPNM Control Panel, you can start and stop the
Intermec Printer Network Manager service manually or
you can launch the Configuration Console.
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Initial Setup

When you click the Configuration console button to
launch the Configuration Console for the first time
after installation, a dialog box will ask you if you want
to run the Configuration Wizard.

Click OK. The Configuration Wizard dialog box
appears.

This Configuration
Wizard dialog box shows
all the steps for Alert
mode. If you are using
View mode, you will see
fewer steps.

For each step, enter the parameters and then click
Next. For help, see the online help.
To exit the Conﬁguration Wizard
• Click Exit. If you made any changes, you are
prompted to save them.
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Conﬁguration
Console
Your Configuration
Console may look different
depending on which mode
you are using. In View
mode you will not see the
Statistics button or the
Alert Log pane.

The Configuration Console is the main window in
IPNM. It is made up of a menu bar, buttons, tabs, and
panes. Depending on if you are using View or Alert
mode, the Configuration Console may look different.
• Across the top, you see a menu bar.
• Below the menu bar and below the right pane, you
see the toolbar buttons.
Advanced EasyLAN/
Standard EasyLAN tabs

Networked Printers
and Groups pane

Printer or Group
Speciﬁcations pane
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Conﬁguration
Console, cont.

• The Networked Printers and Groups pane contains two tabs: Advanced EasyLAN and Standard
EasyLAN. In these tabs, you can see all the networked printers that IPNM found when it scanned
the network.
The Advanced EasyLAN tab contains printers that
can use the full functionality of IPNM. They can
be grouped and they support alerts. They can be
configured by accessing their home pages, by using
Telnet, or by using a remote keyboard. You can also
download files to them using FTP.
The Standard EasyLAN tab contains printers that
cannot be grouped and do not support alerts. However, some printer information can be read and they
can be configured by accessing their home pages and
by using Telnet. You can also download files to them
using FTP.
• The Printer or Group Specifications pane displays
the specifications for the selected printer or group.
• (Alert mode only) The Alert Log pane contains the
alert log, where you can view all alerts handled since
the IPNM service was started.
You can sort the alerts in the Alert Log pane by
clicking any of the column headings.
To close the Conﬁguration Console
• From the File menu, choose Exit.
The Save Settings dialog box may appear to prompt
you to save any changed settings.
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Locating
Networked
Printers

Once you define the scan settings in the Configuration
Wizard or in the Scan Settings dialog box, you scan
the network to locate all your networked printers. By
default, IPNM is configured to scan the local subnet
(255.255.255.255).
You may also want to scan the network when you
change printer settings or when you add a networked
printer.
To scan the network
1. Click the Scan network toolbar button.
At the end of the scan, the Scan result box states
how many Advanced EasyLAN and Standard
EasyLAN printers the scan found.

2. Click Ok. You return to the Configuration Console.
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Naming the
Printers
Advanced EasyLAN =
EasyLAN 100
Standard EasyLAN =
EasyLAN 10/EasyLAN Wireless

Once IPNM has located all your networked printers, you will see them in the Networked Printers and
Groups pane either under the Advanced EasyLAN tab
or under the Standard EasyLAN tab.
Newly found printers are indicated by an exclamation
mark (!), whereas printers that may have been detected
by an earlier scan, but are no longer found, are indicated by a question mark (?).
In the Advanced EasyLAN tab, you will see at least two
folders:
• Add group is used to create a new group.
• Un-grouped contains the list of printers that do not
belong to any group.

Networked Printers
and Groups pane

In the rest of this section, we will only discuss the
printers under the Advanced EasyLAN tab. Standard
EasyLAN printers are only shown as information.
The un-grouped printers have incomprehensible
names, so you should give them more appropriate names and descriptions. The names and the
descriptions are only stored in IPNM; they are not
downloaded to the printers. You can change name and
description anytime.
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Naming the
Printers, cont.

To conﬁgure a printer name and description
1. In the Networked Printers and Groups pane, select a
printer.
2. Click the Name field. A small button appears at the
right side of the line.

Click this button

3. Click the button. The Enter a Printer Name dialog
box appears.

4. In the Friendly printer name field, enter the printer
name.
5. Click Ok. You return to the Configuration Console.
6. Click the Description field. A small button appears
at the right side of the line.
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Naming the
Printers, cont.

7. Click the button. The Enter a Printer Description
dialog box appears.

8. In the Printer description box, enter the printer
description. You can use this description to help you
remember the location of this printer or any other
information that is useful.
9. Click Ok. You return to the Configuration Console.
For the rest of this chapter and the next chapter, let’s
assume that we are the network managers of a small
company network. The company has five networked
printers: two in the goods reception, three in the shipping department. Because the departments are located
in each end of a long building, there is one administrator for each department. The administrator takes care
of out-of-paper and out-of-ribbon conditions, clears
various types of errors etc., so the company does not
have to train everybody how to do it.
In our example, we will name the printers as follows:
• Airline
• Inspection Approval
• Inventory Labeling
• Mail
• Truck & Rail
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Working With Groups
Deﬁning Default
Group and Alert
Settings (Alert
Mode Only)

If you are using Alert mode, you may want to define
which parameters will be set by default whenever a new
group is created. This feature is useful when you need
to create many groups, or when you want to make
extensive modifications. When you add or edit a group,
you will be changing these default settings.
You can reset the settings to what they were when
IPNM was installed by clicking the Use system default
button.
To deﬁne the default group and alert settings
1. From the Tools menu, choose Options. The Default
Group Settings dialog box appears.

2. Define the default group settings and then define
the default alert settings.
3. Click Save changes to save your changes and then
click Exit.
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Deﬁning Default Group and Alert Settings, cont.
Deﬁning the Default
Group Settings

• Use group wide settings
Select Yes or No. Choose yes if all alerts are sent to
the same Email address as specified in the Email
address field. Choose no if you want each alert sent
to the Email addresses that is specified for the alert.
• Alerts activated
Select Yes or No. Enables and disables alerts from all
printers using the default settings (except alerts that
are disabled separately).
• Email address
Enter the Email address of the person who
will receive Emails for all alerts (for example,
name@company.com). Separate multiple Email
addresses with commas.
• Message header
Specifies the header for all alert messages. Click the
button at the end of the text line. The Define Message Header dialog box appears.
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Deﬁning Default Group and Alert Settings, cont.
Deﬁning the Default
Group Settings, cont.

You can:
• Select another variable from a list. To see the list,
click in the Message header box and type % (percent sign).
• Enter text. Click in the Message header box and
type the text for the message header. For example,
you may want to translate to another language.
• Message body
Similar to the message header. Specifies the text for
all alert messages. Click the button at the end of
the text line. The Define Message Body dialog box
appears.

You can:
• Select another variable from a list. To see the list,
click in the Message body box and type % (percent sign).
• Enter text. Click in the Message body box and
type the text for the message body. For example,
you may want to translate to another language.
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Deﬁning Default Group and Alert Settings, cont.
Deﬁning the Default
Alert Settings

There are eight alerts for which you can define these
default settings.
• Alert name
Name of the alert. Read-only information.
• Alert description
Enter a description of the alert.
• Alert activated
Select Yes or No. Choose yes to activate the alert and
choose no to deactivate the alert. If you choose yes,
you can also set these parameters.
• Email address: Enter the Email address of the
person who will receive Emails for this alert (for
example, name@company.com). Separate multiple
Email addresses with commas.
• Message header: Same as the Message header
field in the default group settings.
• Message body: Same as the Message body field in
the default group settings.
• Alert delay unit: Select Occurrences or Seconds. Occurrences counts the number of times
this alert occurs before an Email is sent; seconds
counts the number of seconds that elapses before
an Email is sent.
• Alert delay: Depends on the alert delay unit setting.
If the alert delay unit is set to Occurrences, alert
delay is the number of times an error must occur
before a new alert is sent (0 or 1 is every time, 2 is
every second time, etc.).
If the alert delay unit is set to Seconds, the alert
delay is the minimum number of seconds that
must elapse before a new alert is sent.

Intermec Printer Network Manager v2.0 — User’s Guide

24

Chapter 4 — Working With Groups

Creating a New
Group

In the Advanced EasyLAN tab, you can group printers. You may want to group printers based on their
location, organization, administrator, printer type, or
function.
For example, all printers in the Reception department
may belong to one group with the same administrator and all printers in the Shipping department may
belong to another group with a different administrator.
Using our example, let’s create a group for Shipping.
The administrator is Joe Smith and the description is
“Shipping of customer’s orders.”
To create a new group
1. In the Networked Printers and Groups pane, click
the Add Group folder. The Add Group dialog box
appears.

2. In the Group name field, enter the printer group
name.
3. In the Administrator name field, enter the name of
the person who is reponsible for the printer group.
4. In the Description field, enter a description for the
printer group.
5. Click Ok. The Group Settings dialog box opens.
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Creating a New
Group, cont.

6. Click the Email address field and enter the Email
address of the person who will receive all the alerts
for this group. Usually, you enter the administrator’s
Email address.

7. Change any other properties so they suit the group.
For help, see “Editing a Group” later in this chapter.
8. Click Save changes to save your changes and then
click Exit. This message box appears.

9. Click No. You will download the settings later.

Intermec Printer Network Manager v2.0 — User’s Guide

26

Chapter 4 — Working With Groups

Moving Printers
to Groups
Hint!
Right-click to:
• Cut printer
• Scan printer
• Rename printer
• Move printer
• Delete printer
• Edit group
• Scan group
• Download settings
• Add group
• Delete Group
• Delete all printers in
group

Now, we can organize the networked printers by
moving them into groups. In our example, we are
using a very small network, but for larger networks in
big corporations with local offices in many states or
countries, it is essential to organize the network in an
orderly manner.
You can move a printer to a group by
• using the Move Printer command in the Edit menu.
• right-clicking the printer in the Networked Printers
and Groups pane and choosing Move Printer(s).
You can see the properties of each printer by choosing
it and reading the information in the Specifications
pane. You may need to scroll the pane or resize the
window to be able to see all the information. Only the
first two lines can be changed in IPNM, the rest must
be changed using the printer’s home page.
To move a printer
1. In the Networked Printers and Groups pane, choose
the printer(s) you want to move.
2. From the Edit menu, choose Move Printer(s).
Or, right-click the printer and choose Move
Printer(s).
The Move Printer to Group dialog box appears.

3. In the Move printer(s) to box, choose the group
where you want to move the printer.
4. Click Ok. The printer is now part of the group.
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Editing a Group

Once you have created all your groups, you can edit
the parameters for each group at any time.
To edit a group

Note.
You can also click the
Group settings button.

1. From the Tools menu, choose Options. The Default
Group Settings dialog box appears.
2. In the Settings box, choose Group Settings. The
Group Settings dialog box appears.

3. In the Printer groups box, click the name of the
printer group that you want to edit. The group’s
properties appear in the Group properties box.
4. Edit the parameters. For help, see the next pages.
5. Click Save changes to save your changes and then
click Exit.
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Editing a Group, cont.
Editing the Group
Settings

• Group name, Description, and Administrator
You specified these parameters when you created the
group. To edit the parameters, click in the field and
enter new information.
• Group wide settings
Select Yes or No. If yes, all alerts will be sent to
the same Email address. If no, alerts will be sent to
Email addresses as specified by each alert.
• Activated
Select Yes or No. Choose yes to activate the alert and
choose no to deactivate the alert. If you choose yes,
you can also set these parameters.
• Email address
Enter the Email address of the person who
will receive Emails for all alerts (for example,
name@company.com). Separate multiple Email
addresses with commas.
• Message header
Specifies the header for all alert messages. Click
the button at the end of the text line. The Define
Message Header dialog box appears.
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Editing a Group, cont.
Editing the Group
Settings, cont.

You can:
• Select another variable from a list. To see the
list, click in the Message header box and type
% (percent sign).

• Enter text. Click in the Message header box
and type the text for the message header. For
example, you may want to translate to another
language.
• Message body
Similar to the message header. Specifies the text
for all alert messages. Click the button at the end
of the text line. The Define Message Body dialog
box appears.
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Editing a Group, cont.
Editing the Group
Settings, cont.

You can:
• Select another variable from a list. To see the
list, click in the Message body box and type %.
• Enter text. Click in the Message body box
and type the text for the message body. For
example, you may want to translate to another
language.

Editing the Group
Alert Settings

There are eight alerts for which you can define these
group settings.
• Alert name
Name of the alert. Read-only information.
• Alert activated
Select Yes or No. Choose yes to activate the alert and
choose no to deactivate the alert. If you choose yes,
you can also set these parameters.
• Alert delay unit: Select Occurrences or Seconds.
Occurrences counts the number of times this alert
occurs before an Email is sent; seconds counts the
number of seconds that elapses before an Email is
sent.
• Alert delay repeat: Depends on the alert delay
unit setting.
If the alert delay unit is set to Occurrences, alert
delay is the number of times an error must occur
before a new alert is sent (0 or 1 is every time, 2 is
every second time, etc.).
If the alert delay unit is set to Seconds, the alert
delay is the minimum number of seconds that
must elapse before a new alert is sent.
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Deleting a Group

You should move all printers from the group you are
deleting before you delete the group. There are two
ways to delete a group:
• In the Networked Printers and Groups pane, rightclick the group and choose Delete Group.
• In the Group Settings dialog box, choose the group
and then click Remove Group.
To delete a group in the Networked Printers and Groups pane
1. Move or remove all the printers from the group you
want to delete.
2. In the Networked Printers and Groups pane, rightclick the group you want to delete.
3. Choose Delete Group. A message box appears asking
you to confirm that you want to delete the group.
4. Click Yes. The group is deleted.
To delete a group in the Group Settings dialog box
1. Click the Group settings button. The Group Settings
dialog box appears.
2. In the Printer groups box, choose the group you
want to delete.
3. Click Remove Group. A message box appears asking
you to confirm that you want to delete the group.
4. Click Yes. The printers that were in the group are
moved to the Un-grouped folder and the group is
deleted.
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Downloading
Settings

Now that you have grouped the networked printers
and configured the group alerts, you must download
these settings to the printers.
To download the group settings to the printers
1. In the Networked Printers and Groups pane, rightclick the group where you want to download the
settings and select Download Settings.
Or, from the Tools menu choose Options and then
in the Settings box choose Download Settings.
The Download Settings dialog box appears:

2. Click Check printers to check the printers for
incompatible settings. A message box appears confirming that you want to check the printers.
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Download
Settings, cont.

3. Click Yes. If IPNM finds any errors, it will show you
a dialog box. You need to correct the errors before
you can download the settings. For example:

4. Once you fix any errors in Step 3, go to the Download Settings dialog box, select the group and click
Download settings. A message box appears confirming you want to download the settings to the group.

5. Click Yes. A status box appears showing you the
progress of the download.
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Download
Settings, cont.

6. The Information box tells you if the download was
successful. Click Ok.
If the download was not successful, an error box
appears. You need to fix the errors before you can
download the settings.
When you have successfully downloaded the settings to
all printers (groups), you have these basic functions of
the IPNM running.
• Alert Emails will be sent.
• Alerts will be listed in the Alert log pane.
• Alerts will be logged in a log file.
In Chapter 5, this guide explains how to continue to
manage your groups and printers using IPNM.
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Chapter 5

Managing the Groups and Printers
Deﬁning the
Email Sender
(Alert Mode only)

You need to specify Email information about the
IPNM server that is sending the Email alerts. You can
also send a test Email to verify that you entered the
Email sender information correctly.
To deﬁne the Email sender
1. From the Tools menu, choose Options. The Default
Group Settings dialog box appears.
2. In the Settings box, choose Email settings. The
Email Settings dialog box appears.

You need to specify Email information about the
IPNM server that is sending the Email alerts. You can
also send a test Email to verify that you entered the
Email sender information correctly.

Intermec Printer Network Manager v2.0 — User’s Guide

37

Chapter 5 — Managing the Groups and Printers

Deﬁning the
Email Sender,
cont.

To deﬁne the Email sender
1. From the Tools menu, choose Options. The Default
Group Settings dialog box appears.
2. In the Settings box, choose Email settings. The
Email Settings dialog box appears.
3. In the Mail server field, enter the mail server in your
network.
4. In the From address field, enter the name of the
IPNM server.
Or, if you want to send alerts via the internet, enter
an Email address. For example, you might enter
IPNMServer@yourcompany.com.
5. Click Save changes to save your changes and then
click Exit.
To send a test Email
1. From the Tools menu, choose Options. The Default
Group Settings dialog box appears.
2. In the Settings box, choose Email settings. The
Email Settings dialog box appears.

Note:
The Email address that
you enter in the Send to
field does not need to be
the same Email address as
the alerts, but obviously
you would prefer to test
the communication to the
address where you want
the alerts to go.

3. In the Send to field, enter the Email address where
you want to send the test Email.
4. In the Mail header field, enter the header for the
Email.
5. Click Send test mail. The header in the Mail header
field will be sent to the Email address in the Send to
field.
6. Verify that the Email address received the test Email.
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You can configure IPNM to keep a log file, which
contains all the alerts that appear in the Alert Log
pane. The log file is a text file (.TXT) whose fields are
separated by semicolons. You can easily import the log
file into another program, such as Microsoft Excel,
where you can present the information in your own
customized format.
Also, using this log file, IPNM can generate statistics
for the alerts per group or for the ten printers that have
the most frequent alerts. You must turn on alert logging in order to generate statistics.
To turn on alert logging
1. From the Tools menu, choose Options. The Default
Group Settings dialog box opens.
2. In the Settings box, choose Log settings. The Log
Settings dialog box appears.

3. In the Alert logging box, choose Yes.
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4. In the Log file box, enter the path and filename of
where you want to store the log file.
5. Click Save changes to save your changes and then
click Exit.
To view the log ﬁle
• From the Statistics menu, choose Log file.
Or, from the Log Settings dialog box, choose View
log file.
The log file opens in whatever program you have
designated to open .TXT files (for example, Microsoft
Notepad). Here is an example of a log file:

Ok;2001-10-08 11:23:39;SHIPPING;MAIL;192.168.234.199;00:10:40:00:36:07;Setup Mode;;
Ok;2001-10-08 11:38:15;SHIPPING;MAIL;192.168.234.199;00:10:40:00:36:07;Head lifted;;
Ok;2001-10-08 11:41:29;SHIPPING;MAIL;192.168.234.199;00:10:40:00:36:07;Out of paper;;
Ok;2001-10-08 11:47:12;SHIPPING;MAIL;192.168.234.199;00:10:40:00:36:07;Out of ribbon;;
Syntax:
Status;Date_time;Group;Printer name;IP address;MAC address;Alert name;reserved;reserved
Status can be ”Ok” or ”Not ok”.
Fields are separated by semicolons (;).
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To display statistics
1. From the Statistics menu, choose Statistics.
Or, click Statistics.
The Statistics dialog box appears.

Note:
In order for IPNM to generate statistics, there must
be at least one alert in the
log file and error alerts
must be enabled.

2. In the Select statistic to view field, click the down
arrow on the right side of the field and choose
which statistic you want to display on the screen.
3. Click Close to close this dialog box.
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This dialog box defines the SNMP settings for error
alerts (SNMP traps) and remote configuration. You
can let IPNM set SNMP settings for a group to make
it easier to configure multiple printers. This feature can
be useful if all printers do not have the correct settings
to run with IPNM.
If you are using View mode, the only setting you can
define is the read community.
Intermec recommends that you change all the community passwords to make your network more secure.
To deﬁne the SNMP settings
1. From the Tools menu, choose Options. The Default
Group Settings dialog box (Alert mode) or the
Group Settings dialog box (View mode) appears.
2. In the Settings box, choose SNMP settings. The
SNMP Settings dialog box appears.
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3. (Alert mode only) In the SNMP trap address field,
enter the address where the printer sends alerts.
This address should be the IP address of the IPNM
server.
You may want to use a broadcast address
(255.255.255.255) if the server is located on the
same subnet as the printers.
4. In the Read community field, enter the password for
reading the printer settings. The default is public.
5. In the Write community field, enter the password
for writing to the printer. This password must be
the same on the printer and on the IPNM server or
you will not be able to download settings or use the
remote keyboard. The default is pass.
6. (Alert mode only) In the the Trap community field,
enter the password for the trap community. This
password must be same on the printer and on the
IPNM server. The default is public.
7. Click Save changes to save your changes and then
click Exit.
When you are done configuring the SNMP, you need
to download the settings to the printers. For help, see
“Downloading Settings” in Chapter 4.
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The Scan Settings dialog box defines how IPNM scans
your network for printers when you click the Scan
network button. By default, only the local network
(255.255.255.255) is scanned.
To deﬁne the scan settings
1. From the Tools menu, choose Options. The Default
Group Settings dialog box (Alert mode) or the
Group Settings dialog box (View mode) appears.
2. In the Settings box, choose Scan settings. The Scan
Settings dialog box appears.

Note:
Scanning only takes place
when you click the Scan
network button. After the
initial scan, you only need
to scan the network when
you install a new printer
or change the information
in an existing printer.

You can add, edit, or delete fields until your network
is properly specified. You can also define an IP address
range or subnet to scan and then enable or disable it at
a later date.
For large ranges, such as Class B networks, it may be
better to use a broadcast. (Verify with your network
administrator that your routers will allow broadcasts.)
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There are several ways that you can communicate with
the networked printers:
• Access the printer’s home page to configure the
printer.
• Establish a Telnet session with the printer to configure the printer.
• Use the remote keyboard to configure and manage
the printer.
• Use FTP to download new printer firmware or
EasyLAN interface firmware to the printer.

Accessing the
Printer’s Home Page

While running IPNM, you can open a printer’s home
page and configure it.
To access the printer’s home page
• In the Networked Printers and Groups pane, select
the printer whose home page you want to open and
then click Printer homepage.
A web browser opens with the printer’s home page.
You can configure the printer. For help, see the printer’s user’s manual.
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Establishing a Telnet
Session With a Printer

Telnet lets you communicate with the printer and the
EasyLAN interface over Ethernet as if you are using
a terminal program, such as HyperTerminal. In the
Telnet window, you can type any Fingerprint instructions or programs.
Before you can establish a Telnet session, you must tell
IPNM where it can find the Telnet application. The
Telnet application that you use must be able to accept
the IP address as the first parameter. When IPNM
launches the Telnet application, it sends the IP address
in one command string.
To conﬁgure IPNM for Telnet
1. From the Tools menu, choose Options. The Default
Group Settings dialog box (Alert mode) or the
Group Settings dialog box (View mode) appears.
2. In the Settings box, choose Telnet settings. The
Telnet Settings dialog box appears.
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3. In the Path to Telnet field, enter the path and filename of the Telnet application on your PC.
4. Click Save changes to save your changes and then
click Exit.
To establish a Telnet session with the printer
• In the Networked Printers and Groups pane, select
the printer to which you want to establish a Telnet
session and then click Start Telnet.
If you have an EasyCoder PF2i, PF4i, or PM4i printer,
a Telnet screen appears. The printer firmware and
the firmware of the EasyLAN interface board are
integrated. Telnet communicates with the printer firmware. For helps, see “Using Telnet to Printer.”
If you have a printer with an EasyLAN 10 interface or
an EasyLAN Wireless interface, you can only communicate with the firmware of the EasyLAN interface. A
Telnet screen appears. For helps, see “Using Telnet to
Printer.”
If you have printer with an EasyLAN 100i interface,
the Launch Telnet dialog box appears.

You select which area of the printer you want to communicate with. You can choose:
• Telnet to Printer, which lets you communicate with
the printer firmware (Intermec Fingerprint). To
communicate with the printer’s firmware the printer
communication settings must be correct. For helps,
see “Using Telnet to Printer.”
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• Telnet to EasyLAN, which lets you communicate
with the firmware of the EasyLAN 100i interface.
For helps, see “Using Telnet to EasyLAN.”

Using Telnet to Printer
Before you can communicate with the printer’s firmware, make sure the printer settings are correct by
viewing the printer’s home page in the web browser.
Check that these settings are correct:
• The Standard I/O is set to net1: or auto (see
Configuration/Printer Web Shell).
• The New Line parameter for net1: is CR/LF (see
Configuration/Printer/Communication).
• A TCP port is assigned (see Configuration/Network
Interface/TCP/IP/PRx TCP Port number:).
Submit the new settings and reboot the printer. When
your Telnet session is completed, you may want to
change back the settings.
To use Telnet to printer
• Click Telnet to Printer.
The Telnet application opens with an empty window.
You can type any Intermec Fingerprint instructions.

Using Telnet to EasyLAN
1. Click Telnet to EasyLAN. The Telnet application
opens.
2. In the User field, enter root and in the Password
field, enter pass.
3. At the root prompt, type the desired command, or
type help for a list of commands.
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Keyboard

This feature is only available for printers with an
EasyLAN 100i interface. It displays the front panel
(including LEDs and keyboard) of the printer.
You can view the front panel and LEDs on the printer
as if you were standing in front of the printer.
You can also click the buttons on the remote keyboard
and the printer acts as if you were pressing the buttons
on the printer itself. For example, if you click the Feed
button, a label will feed out from the printer.
To use the remote keyboard
• In the Networked Printers and Groups pane, select
the printer whose front panel you want to access and
then click Remote Keyboard.

The remote keyboard does not continuously scan the
printer for updates to its display. If you want to retrieve
the most current display values, choose Menu and then
choose Refresh.
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Download Files to the
Printer

In older printers, FTP lets you download files to the
printer or to the EasyLAN interface. That is, you can
upgrade the printer firmware or the EasyLAN interface
firmware. You can only transfer files with the file extension .bin.

Note:

If you have a newer printer, such as the EasyCoder
PF2i, PF4i, or PM4i printer, the firmware of the
printer and the EasyLAN interface are integrated. FTP
communicates with the printer firmware. You can also
upgrade Fingerprint and IPL. You can only transfer
files with the extension .net.

You cannot FTP to
printers with EasyLAN
Wireless. You must
download firmware using
TFTP. For more information, see the EasyLAN
Wireless manuals.

Before you can launch FTP, you must tell IPNM where
it can find the FTP application. The FTP application
that you use must be able to accept the IP address
as the first parameter. This is because when IPNM
launches the FTP application, it sends the IP address
in one command string.
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To conﬁgure IPNM for FTP
1. From the Tools menu, choose Options. The Default
Alert Settings dialog box (Alert mode) or the Group
Settings dialog box (View mode) appears.
2. In the Settings box, choose FTP settings. The FTP
Settings dialog box appears.

3. In the Path to FTP field, enter the path and filename of the FTP client on your PC.
4. Click Save changes to save your changes and then
click Exit.
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Note:
For newer PF2i, PF4i, or
PM4i printers, only use
files that have the extension .bin.
For all other EasyCoder printers, if you
are upgrading printer
firmware, only use files
that have the extension
.net. If you are upgrading EasyLAN firmware,
only use files that have the
extension .bin.

Before you can communicate with the printer firmware
or EasyLAN interface firmware, you need to access the
printer’s home page to make sure that:
• The Standard I/O is set to net1: or auto: (see
Configuration/Printer Web Shell).
• The New Line parameter for net1: is set to CR/LF
(see Configuration/Printer/Communication).
• A TCP port is assigned (see Configuration/Network
Interface/TCP/IP/PRx TCP Port number:).
Submit the new settings and reboot the printer. When
your FTP session is completed, you may want to
change back the settings.
To use FTP to download ﬁles to a PF2i, PF4, or PM4i printer
1. Copy the file (.bin) you want to download to your
PC.
2. In the Networked Printers and Groups pane, select
the printer that is receiving the new firmware and
then click Start FTP.

3. Click FTP to Printer.
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4. Log in to the printer. When you have successfully
logged into the printer, the ftp prompt appears. The
default user is admin and the default password is
pass.

5. Enter the command bin and press Enter.
6. Enter the command lcd and then specify the path
and filename of the firmware you want to transfer.
For example,
lcd C:\FIRMWARE

Note:
FLASH is case-sensitive.
Enter this command in
uppercase letters.

7. Enter the command put and then specify the
destination of the file. For example, if you are downloading the MCS1667.BIN file to an EasyCoder
PF2i printer, you enter:
put MCS1667.BIN FLASH

The download starts, and you can watch the progress
in the window.
To download printer ﬁrmware to an older EasyCoder printer
1. Copy the file (.net) you want to download to your
PC.
2. In the Networked Printers and Groups pane, select
the printer that is receiving the new firmware and
then click Start FTP.
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3. Click FTP to Printer.

4. Log in to the printer. When you have successfully
logged into the printer, the ftp prompt appears. The
default user is root and the default password is pass.

5. Enter the command bin and press Enter.
6. Enter the command hash and press Enter.
7. Enter the command lcd and then specify the path
and filename of the firmware you want to transfer.
For example,
lcd C:\FIRMWARE
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8. Enter the command put and then specify the
destination of the file. For example, if you are downloading the MCS1648.NET file to an EasyCoder
501XP printer, you enter:
put MCS1648.NET pr1

The download starts, and you can watch the progress
in the window.
To download EasyLAN interface ﬁrmware to an older EasyCoder printer
1. Copy the file (.bin) you want to download to your
PC.
2. In the Networked Printers and Groups pane, select
the printer that is receiving the new firmware and
then click Start FTP.
3. Click FTP to Printer.
4. Log in to the printer. When you have successfully
logged into the printer, the ftp prompt appears. The
default user is root and the default password is pass.
5. Enter the command bin and press Enter.
6. Enter the command hash and press Enter.
7. Enter the command lcd and then specify the path
and filename of the firmware you want to transfer.
For example,
lcd C:\FIRMWARE

Note:
FLASH is case-sensitive.
Enter this command in
uppercase letters.

8. Enter the command put and then specify the
destination of the file. For example, if you are downloading the EL100I.BIN file, you enter:
put EL100I.BIN FLASH

The download starts, and you can watch the progress
in the window.
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