Contents

Introduction.................................................................5
New in v6.0 ....................................................................6
Requirements .............................................................6
  • System ..................................................................6
  • Printers ..................................................................6
  • SAP R/3 ...............................................................6
Who Should Read This Manual.......................................6
Installation ....................................................................7
Working Modes ..........................................................10
  • Host Mode—Host Stored Label Format .................10
  • Stored Mode—Printer Stored Label Format ...........11
Choosing Working Mode ............................................12
Installing Printers .......................................................13
Finding the Sample Labels ..........................................15
Setting Up Direct Protocol Printers ...............................15
Setting Up IPL Printers ...............................................20
Setting Up EasyCoder C4 Printers .................................24
Label Design .............................................................27
Defining Variable Data ...............................................28
Using Variable Data in Label ......................................30
Advanced Use of Variables ..........................................32
  • Example 1: Code 128 With Manufacturer's Part Number 33
  • Example 2: EAN128 With Two Merged Data Fields 35
Test Print—Host Mode .................................................38
Storing Label in Printer (Stored Mode Only) .................38
  • Using Direct Protocol ............................................38
  • Using IPL ................................................................39
  • Using EasyCoder C4 ............................................39
Making Output File for SAPscript ..............................40
  • Using ERPLabel Wizard ........................................40
  • Using LabelShop ................................................41
Checking the Printer Connection ...............................45
Uploading ITF File to SAP ...........................................46
Creating a New SAP Form (SAPscript) ........................49
Uploading a Code Page ..............................................55
Setting Up an Output Device (Printer) .........................59
Importing a Device Type ..........................................62
Optimizing the Throughput ........................................66
  • Choosing the Font ................................................66
  • Graphics ................................................................67
  • Copies ..................................................................67
How does the printing work in SAP R/3? ................................. 68
General Limitations ............................................................... 69
Printer Setup................................................................................ 69
Using ERPLabel Setup .................................................................... 70
  • General tab.................................................................................. 70
  • Printer tab.................................................................................... 71
Making a Table of SAPscript Variables ......................................... 73
Error Messages............................................................................. 75
Introduction

ERPLabel is a tool to cut down implementation time of bar code label printing in SAP™ R/3® ERP Systems. It will also eliminate the need for output management middle ware products in many cases.

The product will reduce implementation cost, as no middle ware is required. The implementation is also faster, since there is no need to learn programming with a printer command language. ERPLabel™ will provide output files that are used in SAPscript. These can be used without any manual editing, making the procedure quick and easy.

Maintenance cost is reduced as there is no middle ware or separate bar code printing system to maintain, as the printing will use the main R/3 system.
New in v6.0

Version 6 includes new features compared to version 5, including:

- Support for LabelShop PRO v6.11
- Support for EasyCoder C4, PF2i, PF4i, and PM4i printers
- Wizard for creating ITF files
- Support graphics and Stored mode from Direct Protocol driver
- Fingerprint driver no longer supported. You can now use Direct Protocol in Stored mode.
- Support for network installation

Requirements

System

- LabelShop PRO v6.11
- PC running Windows 98/Me/NT4.0/2000/XP
- Hardware requirements—standard for respective operating system
- Microsoft Internet Explorer 5.01 or later

Printers

EasyCoder 201 II, 301, 401, 501, 501 XP, 601, 601 XP, C4, E4, F2, F4, 3240, 3400, 3440, 3600, 4400, 4420, 4440, 4630, 4830, 7421, PF2i, PF4i, PM4i.

SAP R/3

SAP R/3 release 3.0A or later

Who Should Read This Manual

This manual contains the information necessary to install and use ERPLabel for SAP R/3, to set up printers, and upload ITF files to SAP R/3.

This manual was written for users who want to print labels from SAP R/3 on Intermec EasyCoder printers. These users must be familiar with using SAP R/3 and printing from SAP R/3.
Installation

If LabelShop is not installed already, you can install it from the ERPLabel CD. You can install ERPLabel locally or on the LabelShop PRO Net.

**To install ERPLabel locally**

1. Put the ERPLabel CD in your CD drive.

   The CD should now automatically start and display the introduction screen.

   ![Intermec ERP Label for SAP R/3 v.6]

   **Note:** *If the CD does not start automatically, start the Autorun.exe manually from the Start-Run prompt.*
2. Click **Install Software**.

3. If LabelShop is not already installed, select **Install LabelShop PRO**, and follow the instructions that appear.
4. After LabelShop has been installed, select **Install ERPLabel for SAP R/3**.

5. The proposed installation path appears. Click **Yes** to approve. If you want to install it into another path, click **No**, and enter the desired path in the dialog box that appears.

**To install ERPLabel on the LabelShop PRO Net**

1. From the LabelShop CD provided with the LabelShop PRO Net package, install LabelShop PRO Net on the server.

2. At the Network installation type screen, choose **Local installation**.

3. Finish installing LabelShop PRO Net on the server, and then install the clients from the server as described in the Installation Guide of LabelShop PRO Net.

4. Install ERPLabel locally on each of the clients that should use ERPLabel for SAP R/3.
Working Modes

ERPLabel can store label formats locally in the host system, “Host Mode,” or in the printer, “Stored Mode.” Each method has advantages, which are described below.

Host Mode—Host Stored Label Format

- The printer uses the host to send the complete label and data. The major advantage is that no application specific data is stored in the printer, so additional printers can be added or moved in the SAP R/3 system without having to prepare the printer.
- True Type fonts can be used for fixed texts and are sent as graphic data.
- Fixed Graphics are sent to the printer at printout.
- As Host Mode sends all data for every printout, the printout can be slower than Stored Mode, depending on the layout of the label. If graphics are included on the label, the throughput is lower than when using Stored Mode.
- The throughput also depends on the speed of the communication interface between the host and the printer. Using large graphics with slow serial communication or slow Wide Area Network (WAN) links can give unacceptable performance. Stored Mode is preferable for such applications.
Working Modes, cont.

Stored Mode—Printer Stored Label Format

- Can store label formats in printer for optimized throughput. Ideal when using slow communication lines.
- Graphics stored in printer.
- True Type fonts can be stored in printer for use with fixed or variable data.
- Host sends variable data only, minimum overhead.
- As Stored Mode only sends the variable data for the printout, the printout is faster than Host Mode.
- If graphics are included on the label, some printers require Stored Mode as SAPscript cannot send the graphical data in the required format.
- Stored Mode requires some more work and administration to keep it running, as each printer in the system needs to have the stored formats loaded prior to printing from the SAP R/3 system.

1/ On selected printer models.
Choosing Working Mode

The preferred working mode depends on the printer to be used, the application, and preferences.

To choose the working mode

1. Decide which mode to use. The available options are shown in the Working Mode table.
2. Locate the printer model to be used.
3. Follow the instruction for the selected mode.

Hints

- Host mode is recommended and works for most applications. Select this mode and print a test label. If the label prints well, continue using this mode.
- If you need to print a label with lots of graphics and are using slow communication lines, use Stored Mode.

<table>
<thead>
<tr>
<th>Printer/ Language</th>
<th>Language</th>
<th>Host Mode</th>
<th>Stored Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>EasyCoder 3240, 3400, 3440, 3600, 4400, 4420, 4440, 4630, 4830, 7421, PF2i, PF4i, PM4i</td>
<td>IPL</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>EasyCoder 201 II, 301, 401, 501, 501 XP, 601, 601 XP, E4, F2, F4, PF2i, PF4i, PM4i</td>
<td>Direct Protocol</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>EasyCoder C4</td>
<td>ESim</td>
<td>Yes (if no graphics)</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Installing Printers

LabelShop supports a full range of Intermec printers, while ERPLabel works with most of the printers.

To install your printer

1. Select **File > Select printer**, or click the **Select printer** button. The Printer dialog box appears.

2. Click **Add**. The Add printer dialog box appears.

3. Expand the **Intermec Default** folder. ERPLabel only supports printers in the Intermec Default folder.
Installing Printers, cont.

4. From the **Model** frame, select your printer model, and from the **Port** frame, select the port the printer is connected to, and click **OK**.

5. Make sure the printer you added is selected, and click **OK**. LabelShop printers appear with a printer icon in front of the printer name. ERPLabel does not support printers that appear without the printer icon.

The name and port of the selected printer appear in the lower left corner of the LabelShop screen.
Finding the Sample Labels

You can open a pre-defined empty label that contains the correct printer settings. The following empty labels are included Program Files\Intermec\LabelShop PRO 6\Samples\Labels\SAP:

**In the DP folder**
- Empty DP Stored Mode.lab
- Empty DP Host Mode.lab

**In the IPL folder**
- Empty IPL Stored Mode.lab
- Empty IPL Host Mode.lab

**In the C4 folder**
- Empty C4 Stored Mode.lab
- Empty C4 Host Mode.lab

Setting Up Direct Protocol Printers

To get a correct output to SAPscript, the printer settings must be set up properly. You may get an unexpected result if the printer is not set up properly.

This section explains how to set Direct Protocol printers for Host mode and Stored mode.

**To set up Direct Protocol printers for Host mode**

1. Install your printer. For help, see “Installing Printers” earlier in this guide.
2. Click the **Printer setup** button. The Printer settings dialog box appears.
3. In the General tab, set **Send modified data only** to On.
4. Select the Images tab.
Setting Up Direct Protocol Printers, cont.

5. From the **Image format for transfer to printer** drop down list, select ASCII.

6. Select the **Layout tab**.

![Setting up Direct Protocol Printers](image)

7. Set the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store layout in printer</td>
<td>Cleared</td>
</tr>
<tr>
<td>Name images</td>
<td>Cleared</td>
</tr>
<tr>
<td>Start of record</td>
<td>94 (^)</td>
</tr>
<tr>
<td>End of record</td>
<td>125 (})</td>
</tr>
<tr>
<td>Field separator</td>
<td>126 (~)</td>
</tr>
</tbody>
</table>

8. Click **OK**.

Your Direct Protocol printer is ready to print labels in Host mode.

**To set up Direct Protocol printers for Stored mode**

1. Install your printer. For help, see “Installing Printers” earlier in this guide.

2. Click the **Printer setup** button. The Printer settings dialog box appears.
3. In the General tab, set **Send modified data only** to On.
4. Select the Images tab.
5. From the **Image format for transfer to printer** drop down list, select PCX.

6. Select the Layout tab.

7. Set the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store layout in printer</td>
<td>Checked</td>
</tr>
<tr>
<td>Name images</td>
<td>Cleared</td>
</tr>
<tr>
<td>Start of record</td>
<td>94 (^)</td>
</tr>
<tr>
<td>End of record</td>
<td>125 (})</td>
</tr>
<tr>
<td>Field separator</td>
<td>126 (~)</td>
</tr>
</tbody>
</table>

8. Click **OK**.

Your Direct Protocol printer is ready to print labels in Stored mode.
Setting Up IPL Printers

To get a correct output to SAPscript, the printer settings must be set up properly. You may get an unexpected result if the printer is not set up properly.

This section explains how to set IPL printers for Host mode and Stored mode.

To set up IPL printers for Host mode

1. Install your printer. For help, see “Installing Printers” earlier in this guide.
2. Click the Printer setup button. The Printer settings dialog box appears.

3. In the General tab, set the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;STX&gt;&lt;ETX&gt; protocol</td>
<td>Checked</td>
</tr>
<tr>
<td>Send modified data only</td>
<td>Checked</td>
</tr>
<tr>
<td>Reload images at next print job</td>
<td>Cleared</td>
</tr>
<tr>
<td>Maximum number of images</td>
<td>0</td>
</tr>
</tbody>
</table>
Setting Up IPL Printers, cont.

4. Select the Layouts tab.

5. Clear the **Store layout in printer** check box.

6. Click **OK**.

Your IPL printer is now ready to print in Host mode.

**To set up IPL printers for Stored mode**

1. Install your printer. For help, see “Installing Printers” earlier in this guide.

2. Click the **Printer setup** button. The Printer settings dialog box appears.
Setting Up IPL Printers, cont.

3. In the General tab, set the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;STX&gt;&lt;ETX&gt; protocol</td>
<td>Checked</td>
</tr>
<tr>
<td>Send modified data only</td>
<td>Checked</td>
</tr>
<tr>
<td>Reload images at next print job</td>
<td>Cleared</td>
</tr>
<tr>
<td>Maximum number of images</td>
<td>0</td>
</tr>
</tbody>
</table>

4. Select the Layouts tab.
5. Set the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store layout in printer</td>
<td>Checked</td>
</tr>
<tr>
<td>With layout number*</td>
<td>2 to 19 or 2 to 99</td>
</tr>
<tr>
<td>Rebuild the whole label image</td>
<td>Cleared</td>
</tr>
<tr>
<td>List the layouts stored in memory only</td>
<td>Checked</td>
</tr>
</tbody>
</table>

* The number of available layouts depends on the printer model. EasyCoder 3240, 3440, 3400C, 4420, 4440, 7421, PF2i, PF4i, and PM4i printers support 2 to 99 layouts. All other IPL printers support 2 to 19 layouts.

6. Click **OK**.

Your IPL printer is now ready to print in Host mode.
Setting Up EasyCoder C4 Printers

To get a correct output to SAPscript, the printer settings must be set up properly. You may get an unexpected result if the printer is not set up properly.

This section explains how to set EasyCoder C4 printers for Host mode and Stored mode.

**To set up EasyCoder C4 printers for Host mode**

1. Install your printer. For help, see “Installing Printers” earlier in this guide.
2. Click the **Printer setup** button. The Printer settings dialog box appears.

![Print settings dialog box](image)

3. In the General tab, check the **Save settings in the layout** check box.
4. Select the Layouts tab.
Setting Up EasyCoder C4 Printers, cont.

5. Clear the **Store layout in printer** check box.
6. Click **OK**.

Your ESim printer is ready to print in Host mode.

**To set up EasyCoder C4 printers for Stored mode**

1. Install your printer. For help, see “Installing Printers” earlier in this guide.

2. Click the **Printer setup** button. The Printer settings dialog box appears.
3. In the General tab, check the **Save settings in the layout** check box.

4. Select the Layouts tab.
Setting Up EasyCoder C4 Printers, cont.

5. Check the **Store layout in printer** check box.
6. Click **OK**.

Your ESim printer is ready to print in Stored mode.

Label Design

The label design for SAP is done just like any other label design, but there are a few things to keep in mind to make it work smoothly.

**Fixed text:** Can use printer resident or True Type fonts. As True Type fonts are transmitted as graphical bit maps, the printout is slower.

**Variable text:** Only printer resident fonts can be used.

**Lines/Boxes:** Supported.

**Bar codes:** Fixed and variable supported. Use printer bar codes only.

**Graphics:** Use fixed graphics only.

**Polygons, circles, rounded rectangles:** Printed as graphics.

**Oblique lines:** Printed as graphics (except EasyCoder C4).

**OLE objects:** Printed as graphics.
Defining Variable Data

When using variable text fields in the label, you should use the variable field names as used in SAP.

Variable (formula) names cannot contain curly brackets ({}) or ampersands (&).

If a variable used in the formula has a name containing one of the characters: + - * / < > = ^ % ! \ , you must enclose the variable in curly brackets {}.

If you want to use the underscore character in a name, enter a double underscore, such as SY__NAME for SY_NAME. The double underscore will be converted to a single underscore.

To define variable data

1. Click the Display Document Browser button.
2. In the Data Sources tab, right click Form, and select Add. Var0 appears under Form.
3. Click Var0 to select it, click again or press F2, enter the name of the field in SAP that the variable is for, and press Enter.
4. Double click the variable. The variable dialog box appears.
Defining Variable Data, cont.

5. In the Input tab, enter a sample value in the field in the **Variable value** box so that the screen displays some typical data.

6. Select the Output tab.
7. In the **Maximum length** field, enter the maximum number of characters for the field.

8. Click **OK**.

1. Click and drag the variable you want to add to the label to the label frame. A dialog box appears.
Using Variable Data in Label, cont.

2. Select whether you want the variable to display as text, bar code, or image. The variable data appears on the label. The following screen capture shows Part_No as a bar code.

3. To move the variable data, click the Select Objects button, and then click and drag the variable data to where you want it.

4. To change the parameters for the variable data, such as font type or bar code symbology, click the Select Objects button, and then double click the variable data.
Advanced Use of Variables

It is possible to design concatenated fields using formulas. Concatenated Fields are useful when you want to:

- merge two or more R/3 fields.
- combine R/3 fields with fixed data.
- combine R/3 fields with non-printable characters.

Formulas can include control characters, EOT (ASCII 4), GS (ASCII 29), and RS (ASCII 30). Including control characters is useful when printing bar codes with embedded control characters, for example in EDI messages in two dimensional (2D) bar code symbologies.

When building formulas for UCC/EAN 128 bar codes, FNC1 (Function Code 1) is needed. You use the control character (FNC1) in for such cases. For more information, see “Example 2: EAN128 With Two Merged Data Fields” later in this guide.

Note: Printer fonts normally do not print control characters.

Note: When using control characters in the labels in combination with Direct Protocol and EasyCoder C4 printers, you must change the code page in SAP to Code Page 9163 for LB_UBI/ZLB_UBI (Direct Protocol) and Code Page 9999 for ZLB_C4. For help loading code pages, see “Uploading a Code Page” later in this guide.

LB_INT and ZLB_INT device types support control characters (including FNC1) by default.

To design a concatenated field

1. Declare the individual fields, even if they are not used separately.

2. Create the concatenated field using a formula.

The following examples explain how to create specific concatenated fields.

### Special Characters Syntax

<table>
<thead>
<tr>
<th>Character</th>
<th>ASCII Value (dec)</th>
</tr>
</thead>
<tbody>
<tr>
<td>{EOT}</td>
<td>4</td>
</tr>
<tr>
<td>{GS}</td>
<td>29</td>
</tr>
<tr>
<td>{RS}</td>
<td>30</td>
</tr>
</tbody>
</table>
Example 1: Code 128 With Manufacturer's Part Number

Example 1 explains how to create the following label including a Code 128 bar code with the manufacturer's part number, using a FACT Data Identifier (DI). The DI for part number is 1P.

This label, “Code 128 XX Host Mode.lab” (XX=IPL, DP, or C4), can be found in the Samples\SAP directory.

To create the Example 1 label

1. Define a variable named Part_No with a length of 20. For help, see “Defining Variable Data” earlier in this guide.

2. Define a variable named Description with a length of 25. For help, see “Defining Variable Data” earlier in this guide.

3. In the Data Sources tab, right click Formula0, and select Add. Formula0 appears.

4. Select Formula0, then click Formula0 or press F2 to make the name editable, and enter Formula BC_PN.

5. Right click Formula BC_PN, and select Variable properties. The Formula BC_PN dialog box appears.
Advanced Use of Variables, cont.

6. Type "1P"&.
7. Select Variables, select Part_No, and click Insert.
8. Select the Output tab.
Advanced Use of Variables, cont.

9. In the **Maximum length** field, enter 22.
10. Click **OK**.
11. In the Data Sources tab, right click Formula (1), and select **Add**. Formula1 appears.
12. Select Formula1, then click Formula1 or press **F2** to make the name editable, and enter Formula HR_PN.
13. Right click Formula HR_PN, and select **Variable properties**. The Formula HR_PN dialog box appears.
14. Type "(1P) "&. (There is a space after the close parenthesis.)
15. Select **Variables**, select **Part_No**, and click **Insert**.
16. Select the Output tab, and set the length to 24.
17. Drag the formulas and variables to the label, and select **Text** or **Barcode** as appropriate.

**Example 2: EAN128 With Two Merged Data Fields**
Example 2 explains how to create a label including an EAN128 bar code with two merged data fields.

![ERPLabel Example](image)

This label, “EAN128 Var Length XX Host Mode.lab” (XX=IPL, DP, or EasyCoder C4), can be found in the Samples\SAP directory.
Advanced Use of Variables, cont.

The bar code should include two internal data fields:

- AI for Location is 90 (Internal Use only)
- AI for Product Group is 91 (Internal Use only)

As the length of the fields are not fixed, you need to put a separator character (that is, an FNC1) between the Location Field and the AI for the product group, that is \{FNC1\}&90&Location&\{FNC1\}&91&Product_Group.

**To create the Example 2 label**

1. Define a variable named Location with a length of 10. For help, see “Defining Variable Data” earlier in this guide.

2. Define a variable named Product_Group with a length of 10. For help, see “Defining Variable Data” earlier in this guide.

3. Define a variable named Product_Name with a length of 25. For help, see “Defining Variable Data” earlier in this guide.

4. In the Data Sources tab, right click Formula, and select Add. Formula0 appears.

5. Select Formula0, press F2 or click again, and enter Formula BC_LOC_PG.

6. Right click Formula BC_LOC_PG, and select **Variable properties**. The Formula BC_LOC_PG dialog box appears.

![Formula BC_LOC_PG dialog box](image-url)
Advanced Use of Variables, cont.

7. Type "{FNC1}" & "90" &.
8. Select Variables, select Location, and click Insert.
9. Type & "{FNC1}" & "91" &.
10. Select Variables, select Product_Group, and click Insert.
11. Select the Output tab.

12. In the Maximum length field, enter 26.
13. Click OK.
14. In the Data Sources tab, right click Formula, and select Add. Formula1 appears.
15. Select Formula1, then click Formula1 or press F2 to make the name editable, and enter Formula HR_LOC_PG.
16. Right click Formula HR_LOC_PG, and select Variable properties. The Formula HR_LOC_PG dialog box appears.
17. Type "(90) " &.
18. Select Variables, select Location, and click Insert.
19. Type & "(91) " &.
20. Select Variables, select Product_Group, and click Insert.
21. Select the Output tab, and set the length to 28.
22. Click OK.
23. Drag the formulas and variables to the label, and select Text or Barcode as appropriate.
Test Print–Host Mode

When the label has been completed, it is time for a test print prior to getting the label into the SAP R/3 system.

Print the label by clicking the Print button or selecting **File > Print**.

When you are satisfied with the result, make sure the file is saved. If the printer driver was set to Stored mode, an additional dialog box appears. For more information, see the next section.

Storing Label in Printer (Stored Mode Only)

If you are going to use Stored mode, you have to store the current label layout in the printer.

You store the layout while printing the current label to the connected printer. It works slightly differently depending on the printer attached.

Using Direct Protocol

When you print the label, you are prompted for a layout name. Existing stored labels are shown.

![Save the layout dialog box](image)

Enter a suitable name in the Layout name field. Make a note of the name as you need to enter it when the script is saved for SAPscript.

*Note:* If you use a name of a current layout, that layout will be overwritten.
Storing Label in Printer, cont. (Stored Mode Only)

Using IPL
The layout will refer to the number selected in the driver settings (in the Forms tab).

Note: If the printer contains a layout on the current store position, it will be overwritten.

Using EasyCoder C4
When you print a label, you are prompted for a layout name. Enter the desired name of the label. You can use a maximum of eight characters for the layout name. Ignore the KDU country code.

If the layout contains graphics, you are prompted for the name of each graphic. Enter a name up to eight characters long. Each graphic must have a unique name, no matter what layout it is in.
The SAP R/3 system requires a specific output format (ITF file) to be used. You can create the ITF file using the ERPLabel Wizard or using LabelShop.

**Using ERPLabel Wizard**

1. Create your label, and save it to disk. For help, see the LabelShop documentation.

2. Set up your printer. For help, see one of the sections for setting up printers earlier in this guide. The target printer must be installed before you run the Wizard.

3. From the Start menu, select Programs > Intermec ERPLabel for SAP > ERPLabel Wizard. The ERPLabel Wizard screen appears.

   From LabelShop, select Tools > ERPLabel Wizard.

4. Click Next, and follow the instructions that appear in each screen.

   If you choose Stored mode for a Direct Protocol or EasyCoder C4 printer, you are prompted for the layout name that you set in “Storing Label in Printer” earlier in this guide.

5. When the ITF file has been successfully created, the following screen appears.

   If there is an error, follow the hint that appears on the screen, or see “Error Messages” later in this guide to correct the error.
Making Output File for SAPscript, cont.

6. To open the ITF file in a text editor, such as Notepad, click **Open destination folder**.

7. In the Finished dialog box, click **Back** to step back and create a different ITF file, or click Exit.

**Using LabelShop**
This section explains how to create ITF files in LabelShop for Host mode and Stored mode.

**Host Mode**
1. Create your label, and save it to disk. For help, see the LabelShop documentation.

2. Set up your printer for Host mode. For help, see one of the sections on setting up printers earlier in this guide.

3. Select **File > Export > as a printer object file (POF) > Template SAP HostMode.poc**. The Save As dialog box appears.
Making Output File for SAPscript, cont.

4. Save the file with your desired name on a location where the SAPscript can reach it. By default, the Print directory of LabelShop is proposed, but it can be changed at will.

LabelShop creates an ITF file with the same name, but with the extension ITF. The original file is deleted. For example, if you created the output file `sap_addr.pof`, LabelShop generates the file `sap_addr.itf`. 
Making Output File for SAPscript, cont.

Stored Mode
1. Create your label, and save it to disk. For help, see the LabelShop documentation.

2. Set up your printer for Stored mode. For help, see one of the sections on setting up printers earlier in this guide.

3. Select File > Export > as a printer object file (POF) > Template SAP StoredMode.poc. The Save As dialog box appears.

4. Save the file with your desired name on a location where the SAPscript can reach it. The default directory is the Print directory of LabelShop.

   If you are using a Direct Protocol or EasyCoder C4 printer, you are prompted for the layout name after you click Save. For help, see “Using Direct Protocol” or “Using EasyCoder C4” earlier in this guide.

   LabelShop creates an ITF file with the same name, but with the extension ITF. The original file is deleted. For example, if you created the output file sap_addr.pof, LabelShop generates the file sap_addr.itf.
Using Direct Protocol
When prompted for a layout name, enter the desired name.
Enter the same name as entered when the layout was stored when printing. If a different name is given, SAPscript will not print the label correctly.

Using IPL
The layout refers to the number selected in the driver settings (in the Forms tab).

Using an EasyCoder C4 Printer
When prompted for a layout name, enter the desired name.
Enter the same name as entered when the layout was stored when printing. If you enter a different name, SAPscript will not print the label correctly.

If the layout contains graphics, you are prompted for a name for each graphic. The name of the graphic must be identical to those entered when the layout was stored when printing. If you enter a different name, SAPscript will not print the label correctly.
Making Output File for SAPscript, cont.

Checking the Printer Connection

Prior to printing from SAP R/3, the printer connection should be checked outside of R/3. This will confirm that the printer is properly connected to the operating system, prior to creating the output devices in R/3.
Uploading ITF File to SAP

You use transaction SO10 to copy the contents of the ITF file into a clipboard area in SAP, which can then be pasted into the SAP Form.

**Note:** This manual uses SAP R/3 v4.6c to describe handling of ITF files, code pages, and Device Types. Some steps may be slightly different in other versions of SAP R/3, but experienced SAP users should be able to use this guide to help them accomplish the steps.

**To upload ITF file**

1. Log in to SAP.
2. Go to transaction /NSO10.
3. In the **Text name** field, enter a name, and then click **Create**.
Uploading ITF File to SAP, cont.

4. Select **Goto > Change Editor**.

5. Select **Text > Upload**.

6. Select the **ITF** radio button, and press **Enter**.

7. At the end of the **ITF file** field, click the **Drop down** button, browse to your ITF file, and open it.
8. Place your cursor on the first row on the first column of the paragraph format (not text), and press F2.

9. Scroll to the end of the text, place the cursor on the last line on the first column of the paragraph format field, and press F2. All of the text is now highlighted.

10. Select Edit > Selected area > Copy to user clipbrd > Clipboard 1.

11. Click Exit.

12. When prompted to cancel text, click Yes.
Creating a New SAP Form (SAPscript)

1. In SAP R/3, go to transaction /NSE71.

2. In the Form field, enter a name for your new SAP form (SAPscript), and click Create. A message box appears.

3. Click the Check button.
4. In the **Description** field, enter a description for the form.
5. Click **Pages**.

   ![Image of SAP Form Change Pages window]

6. In the **Page** field, type FIRST, and press **Enter**.
7. In the **Description** field, type First Page.
8. Click **Paragraph formats**.
9. In the Paragraph field, type X, and press Enter.
10. In the Descript. field, enter a description, and then press F5.
11. Click Basic Settings.

12. In the Default paragr. field, type X.
13. In the First page field, type FIRST.
14. Click Page windows, and select Edit > Create Element.
Creating a New SAP Form (SAPscript), cont.

15. Double-click the entry for MAIN.

16. In the **Window width** field, type 210.00 MM, and in the **Window height** field, type 291.00 MM.

17. Press **F9**, and select **Goto > Change Editor**.
Creating a New SAP Form (SAPscript), cont.


Creating a New SAP Form (SAPscript), cont.

20. Press Ctrl + S.

21. Assign a development class and transport as needed, or click Local Object if this is only a test form.

22. Select Form > Activate.

23. Create a new ABAP print program, or modify an existing one, as necessary.
Uploading a Code Page

You need to use a non-standard code page in the following situations:

- For the EasyCoder C4 printer, you need Code Page 9999.
- For printing the Euro character (€) and special non-printable characters on Direct Protocol printers, you need Code Page 9163.
- For printing the Euro (€) character on IPL printers, you need Code Page 9998.

To upload a Code Page

1. In SAP R/3, go to transaction SPAD.

2. Select Utilities > For Character Sets > Import.
3. In the **Character set number** field, enter 9163 for Direct Protocol, 9998 for IPL, or 9999 for EasyCoder C4.

4. Check the **File system: GUI** check box.

5. Select the **Upload (file -> R/3)** radio button.

6. Check the **Update/delete when uploading** check box.

7. Click the **Execute** button.

8. Click **Yes**.
9. Assign a development class and transport as necessary.

10. Click **Save**.

11. Click the **Drop down** button for the **File name** field.

12. Browse to the character set file, S9999.cpa, S9998.cpa, or S9163.cpa, select it, and then click **Open**. On the CD, the files are under `\Codepages\`.

13. Verify the file path, and then click **Transfer**.
14. Review the upload report for errors.
Setting Up an Output Device (Printer)

1. Log in to SAP.
2. Go to transaction /NSPAD, and select the Devices/Services tab.
3. Clear the Output devices field, and then click the Output devices button.
4. Press F8, and then press Shift + F1.
5. In the **Output device** field, enter a descriptive name for the printer, and in the **Short name** field, enter a short name for the printer.

6. From the **Device type** drop down list, select the type of printer you have: LB_INT (IPL) or LB_UBI (Direct Protocol).

   Older versions of SAP R/3 need ZLB_INT (SAP note 183777) or ZLB_UBI (SAP note 137069).

   If you have an EasyCoder C4 printer, load the device type ZLB_C4 from the ERPLabel CD. For help, see the next section, “Importing a Device Type.”

7. In the **Spool server** field, select the location that houses the print queue.

8. Click the HostSpoolAccMethod tab.
Setting Up an Output Device (Printer), cont.

9. In the **Host spool access method** drop down list, select **L: Print locally using LP/LPR**, and in the **Host printer** field, enter the queue name.

10. Save settings.
1. Upload the required code page. For help, see “Uploading a Code Page” earlier in this guide.

2. In SAP, go to transaction SPAD.

3. Select Utilities > For Device Types > Import.
4. Select the **Device Type** radio button.

5. In the **Object name** field, enter ZLB_C4 for the EasyCoder C4 printer, ZLB_INT for IPL printers, or ZLB_UBI for Direct Protocol printers.

6. Click the **Execute** button or press **F8**.
Importing a Device Type, cont.

7. Assign a development class and transport as necessary.
8. At the end of the **File name** field, click the **Drop down** button, and browse to the ZLB_C4.PRI, ZLB_INT.PRI, or ZLB_UBI.PRI file.

9. Click **Transfer**. The following screen appears confirming that the device type has been imported.
Optimizing the Throughput

If you find the throughput is not satisfactory, use the hints below to optimize the speed.

Choosing the Font
Choose between printer resident fonts, bitmapped fonts, and scaleable fonts.

To change the font
- Double click the text in the label. The Text dialog box appears.

Printer Resident Fonts
You should also use printer resident fonts for fixed text. If you use Windows fonts, these fonts are sent as graphics causing the label to print slower.

You can scale printer resident fonts in various ways. There are two types of fonts: bitmapped or scaleable (sometimes referred to as outline fonts).

**Note:** You must use printer resident fonts for variable text.
Optimizing the Throughput, cont.

Bitmapped fonts
Bitmapped fonts are fixed size fonts that you can expand (multiply) either horizontally or vertically. This expandability enables you to get a narrow font by expanding the height by 2 and keeping the width at 50%.

Example:
First set the point size to 5, then the height to 2, and then decrease the width to 50%.

Scaleable Fonts
You can scale these fonts into any size. Width can be entered in percent of the nominal width, which makes it very flexible.
Select the point size (or mm or inch) and then the width and height in percent, if the nominal size doesn’t meet your needs.

Example:
First set the height to 16 points, then decrease the width to 67%.
If Windows fonts are required and speed is essential, use Stored mode as an alternative.

Graphics
Minimize the amount of graphics and the size of the graphics if possible. Consider to use Stored Mode if this is practical.

Copies
If printing multiple identical labels, the speed can be increased by using the Multiple Copies function. For help, see one of the sections on setting up printers earlier in this guide.
If you have defined an Intermec EasyCoder printer in your R/3 system, for example “P1,” in runtime SAPscript merges the defined ITF file with the data from your R/3 database and send it to the spooler as an OTF file.

The printing is made using a specific device type used for the “upload method,” which is the technique utilized by ERPLabel.

The generated spool file is handled by the Generic Text Driver of the Operating System.

How does the printing work in SAP R/3?
As ERPLabel uses /& as a placeholder for the variables, do not use this string in a label. If used, an Error Message appears (Error 513 – Odd number of field delimiters).

The Direct Protocol uses some printable characters in the communication protocol. These are user definable, but are preset to:

- Start of record \^ (ASCII 94 dec.)
- End of record } (ASCII 125 dec.)
- Field separator ~ (ASCII 126 dec.)

Selecting Direct Protocol - Override Protocol overrides the protocol delimiters set in the LabelShop driver. If you need to use delimiters for data, you can use up to three start and stop characters, e.g. ### and $$$, which enables you to use a single or double character as data. The record separator can only be a single character. This feature is not supported for EasyCoder 301 and E4 printers.

The printer driver must be set up properly to obtain the expected results that SAPscripts expect. There is a separate section for each printer command language and mode. Follow these instructions carefully.
Using ERPLabel Setup

There is a fine tuning tool included in the ERPLabel. The purpose is to set some parameters that can improve the performance or assist in Debugging in case an error should occur.

To access ERPLabel setup

- In LabelShop, select Tools > ERPLabel Setup. The ERPLabel Setup dialog box appears.

![ERPLabel Setup dialog box]

General tab
Use the General tab to set the following parameters.

Output File Line Length
Sets the maximum length of the ITF file lines. Default is 74. SAPscript can not accept more than 74.

Post Process > Remove Input File
Default On. Set it to Off, if you want to keep the initial POF file even after converting it to a ITF file, for debugging purpose.

Post Process > Show Input File
Default Off. Set it to On, if you want to bring up the Input File in your favorite editor during the test phase. You will have to associate the extension for the POF file with your Editor, to make it work.

Post Process > Show Output File
Default Off. Set it to On, if you want to bring up the ITF File in your favorite editor during the test phase. You will have to associate the ITF extension with your Editor, to make it work.
Multiple Copies
By default, SAP R/3 will send down the complete label data for every printed label. It is possible to maximize the printer throughput when printing multiple copies of a label. If the “Multiple copies” box is enabled, it is possible to specify a field name that contains the SAP variable for print quantity. Default name is ZERP-QTY, but it can be changed to any desired name.

Note: The SAP application must enable the user to specify the number of copies variable at print time.

Printer tab

Use the Printer tab to set the following parameters.

Remove Setup
The ITF file normally contains setup strings to set the printer to the number of parameters, for example desired print mode, select media type, print contrast, direct thermal or thermal transfer printing.

If the printer uses the same media type and size at all times, this information may not be necessary to send with every label. For these cases, you can configure the printer to use that media and check the Remove Setup check box.
Using ERPLabel
Setup, cont.

Direct Protocol - Override Protocol
The Direct Protocol uses some printable characters in the communications protocol. These are user definable, but are preset to:

Start string  ^  ASCII 94 dec.
End string  }  ASCII 125 dec.
Separator character  ~  ASCII 126 dec.

A string of characters sent to the printer with this setting looks like this:

^11-900000-92~ERPLabel~Add on for LabelShop PRO~}

To enable correct printing, the variable data must not contain any of the delimiter characters.

In applications where there is no possibility to reserve three printable characters, the Override protocol will override the standard protocol and enable you to define a reserved one to three character string for Start string and End string. The Separator character will maintain a single character.

Note: EasyCoder 301 and EasyCoder E4 do not support Override protocol, as they can only use one delimiter.

Start string
Select the desired two or three characters from the drop down list.

End string
Select the desired two or three characters from the drop down list.

Separator character
Select the desired single separator character from the drop down list.
Making a Table of SAPscript Variables

If you are designing several labels it may be useful to pre-define the variables. Instead of having to define the fields every time, you can re-use the field names over and over.

To reuse field names, create an ASCII table with comma-delimited records.

Sample database

Part_No,Product_Name,Description,Location,Product_Group
"11-900000-92","ERPLabel","Add on for LabelShop PRO","656A1","SW"
"11-300200-02","LabelShop PRO","Label Design Software","887B2","SW"
"11-400300-02","LabelShop ULTRA","Label Design Software","888B2","SW"

ERPLabel includes such a table, Products.txt. It can be found in the Data directory.

To make a table of SAPscript variables

1. Create a text file with the fields and some sample records as previously shown, and place this file in the Data directory.
2. Create a describer file. (Consult the LabelShop manual or the On-line help for details).
3. To use the database in the design mode, in LabelShop select Merge > Open ASCII database or press F9.

4. In the Data file box, click the button to open the text file you created.
5. In the Describer box, click the button to open the describer you created.
6. Click OK.
The variables are now available in the Database section of the Document Browser.
**Error Messages**

**Error 513. Odd number of field delimiters**
ERPLabel uses the string “/&” to identify the variables. This error may show if you have used “/&” in a text string in the label. Change the string to use some other data, for example “/ SPACE &” or substitute the “&” character with the word “and.”

**Error 514. Driver not set to Stored Mode**
You have tried to generate a file for Stored Mode, but the driver is set to Host Mode.

Change the driver to use Stored Mode in Printer-Settings-Layout.

Change the driver to use Stored Mode in Printer-Settings-Layout, that is, check the box “Store layout when printing.”

**Error 515. Input file X:\Path\Filename.POF contains non-printable characters**
SAPscript does not permit non-printable characters.
You have probably used a graphic text or bar code object for a driver that does not permit such data.
Check that you have not, for example, ....
• defined a graphical bar code—change to a printer bar code
• defined a graphical text for a DP driver.

**Error 516. POF file corrupt or empty**
The POF file has been corrupted or damaged. Please check that a correct file has been generated. Make a new try. If problem occurs again, please contact your supplier.

**Error 518. Driver not set to <STX><ETX> protocol**
You have tried to generate an ITF file from an IPL driver. The printer driver is not correctly configured, as it will generate non-printable characters. Go to Printer > Settings > General. Activate the tick box <STX><ETX> protocol, and try again.

**Error 519. Driver not set to Host Mode**
You have tried to use Host Mode output, but the driver is set to Stored Mode.
Change the driver to use Host Mode in Printer-Settings-Layout, that is, uncheck the box “Store layout when printing.”
Error Messages, cont.

Error 520. No input file *.POF could be found
The POF was never created. Please retry. If problem continues, check your LabelShop and ERPLabel installation.

Error 521. Formula: xxxxxxxxxx Function not allowed.
Formula contains non-supported expression.
You have used expressions in the formula that ERPLabel does not support. This may, for example, be a check digit calculation or a logical expression. ERPLabel supports only concatenation of constants, variables, and special characters.

Error 522. Formula: xxxxxxxxxx Char Function not supported.
You have tried to use an ASCII character using the char(nnn) statement. Use the printable syntax, for example {RS} for ASCII 30.

Error 523. Formula: xxxxxxxxxx Nested formula not supported.
You cannot use a formula inside another formula. Make the variable as a formula in one step.

Error 524, File ERPSYS.INI contains invalid settings.
Settings have been corrupted. Re-install the software.

Error 525, Data separator should be a printable character
The DP driver must be set to use a printable character. Go to the layout tab of the printer settings and select three printable characters as data separators. Detailed information can be found in “Setting Up Direct Protocol Printers” earlier in this guide.

Error 526, The driver has to be set to 'Send modified data only'
In order to provide correct output, the driver must be set to ‘Send modified data only’. Click Printer setup and go to the General tab. Detailed information can be found in one of the sections for setting up printers earlier in this guide.

Error 527, Formula: xxxxxxxxxx. Formula name or variable name cannot contain '& character
As SAP R/3 uses & to tag variables, the ampersand (&) character cannot be used in formula names or variable names. Change the formula or variable name to remove the ampersand.
Error Messages, cont.

Error 528, Formula contains string without quotes
Strings in a formula must be written within quotes, for example, “1111”&VAR-1&“2222”&VAR-2.

Error 529, Fingerprint mode not supported. Use DP mode driver instead
Fingerprint drivers cannot be used in ERPLabel 6. Install the DP mode driver for this printer instead. Press F5 to add a printer, and select it from the Printer group Intermec default.

Error 530, Code page conversion table is corrupted or could not be found
Check if the file “cmap.txt” is present in the ERPLabel directory. If it is missing, reinstall ERPLabel.