INTERMEC Device Management Resource Kit

(RELEASE 3.50) Release Notes

© 2000-2014  INTERMEC TECHNOLOGIES CORP., ALL RIGHTS RESERVED

 

Contents

VERSION HISTORY

REQUIREMENTS

FIXES THIS RELEASE

TIPS

UNDOCUMENTED FEATURES

 

VERSION HISTORY

Ver #

Description

3.50

Added support for CV31 and example C# VS2008.  User’s Guide has been updated to include ITCSSUninit.

3.42

Fixed issue with .NET applications remaining in the process list after closing.  Also updated all C++ binaries to be compatible with new OS release 1.50 for Windows Mobile.

3.41

Added support for CV61.

3.40

Added assembly built with .net CF 3.5.  Updated user’s guide.  Corrected issue with timeOut parameter not taking effect.

3.32

Added support for FLEXnet Connect v12.

3.31

Fixed the bug where loading/unloading of ITCSSAPI.dll between operations might cause the unit to hang.  Also updated examples.

3.30

Added Java API

3.20

Added support for CK3-WM6  and CN3-WM6 platforms to all interfaces in the resource kit.  Also added support for CV60-XP platform to the C++ ITCSS functions only. 

3.10

Added web API.

3.00

Separate IDL into individual Resource Kit installs.

2.05

Added support for configuring any setting listed in Intermec Settings programmatically.  A SmartSystems device is required.

1.00

Initial release.

 

NEW FEATURES

     Added to support CV31 in 3.50

FIXES

      Updated User’s Guide to include ITCSSUinit in 3.50

Fixed issue with .NET applications remaining in the process list after closing.  The fix is available in the Intermec.DeviceManagement.SmartSystem.ITCSSAPI.DLL for .NET Compact Framework and Full Framework 3.5, which are located at <installed Directory>\Intermec\Developer Library\Dot NET Assemblies.

Also updated all C++ binaries to be compatible with new OS release 1.50 for Windows Mobile.

KNOWN ISSUES

An error can occur when you try to install Intermec software (such as IDL Resource Kits) using an invalid version of agent.exe. Agent.exe is part of Intermec's 3rd-party software update system called FLEXnet Connect – more commonly known as Intermec Update. Several Intermec Software components utilize FLEXnet Connect, such as SmartSystems, All IDL Resource Kits and Toolkits, DEX Toolkit and Verdex. This error may also occur if any 3rd party software utilizing version newer than v6 of FLEXnet Connect has been installed on your system.  .  If you encounter an error similar to: “"The file 'agent.exe.4747EFCD_A8CE_4016_80F6_BCAD9FE72' is not marked for installation." please contact Product Support or Developer Support.

TIPS

          None

UNDOCUMENTED FEATURES

          None

REQUIREMENTS

 

1) You need these hardware components to use the Intermec Device Management Resource Kit:

 

     Pentium PC, 400 MHz or higher

 

     256MB RAM

 

     360MB Hard drive space for minimum installation (720MB for complete)

 

     CD-ROM drive compatible with multimedia PC specification

 

     VGA or higher-resolution monitor (Super VGA recommended)

 

     Microsoft Mouse or compatible pointing device

 

2) Windows XP or Windows 7 (Home, Professional, or Server) operating system is recommended.

 

3) Microsoft Embedded Visual C++ (EVC) version 4.2 or later is required for building Windows CE, C or C++ applications.

Visual Studio 2005 or later is recommended for developing .net or Windows Mobile applications.

 

4) ActiveSync 3.7 or later is needed to download the applications to the devices.